Issue Saving Customers
Incident Report for foreUP
Resolved
This incident has been resolved.
Posted Sep 01, 2023 - 15:24 MDT
Monitoring
A fix was implemented and we are monitoring results.
Posted Sep 01, 2023 - 15:18 MDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 01, 2023 - 15:15 MDT
Identified
The issue has been identified with saving customer information and we are currently working on a fix.
Posted Sep 01, 2023 - 14:49 MDT